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3skeng - Starting Guide 

 

To use 3skeng tools and libraries for SketchUp on your computer, you may follow 

the whole guide or just jump to topics of interest by clicking on a title below! 
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1) Download 3skeng 

 

Go to www.3skeng.com and browse to the download section. 

 

Download Ruby file for the installation of the 3skeng extension in SketchUp for both MAC OS and 

Windows OS. 

  

http://www.3skeng.com/
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2) Installation of 3skeng 

 

Installation of 3skeng by Ruby file for SketchUp 

- IMPORTANT: 

  Login on your computer as the user (account) who will use SketchUp with 3skeng! 

- Select Extensions > Extension Manager (as of SketchUp 2021) 

   Select Window > Extension Manager (up to SketchUp 2020) 

   The Extension Manager dialog box is displayed. 

- Click on Install Extensions (see screenshot). The Open dialog box is displayed. 

- Locate the Ruby zip file to install (3skeng_xxxx.rbz). 

- Click on the Open button. 

- After the installer completes, quit and restart SketchUp. 

 

 

 

- Open the “Extension Manager” dialogue box again. 

- Make sure that “3skeng Engineering 20xx” can now be found in the list of extensions 

  and the button is set to “Enabled”. 
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3) Request activation key for 3skeng 

 

a) Open SketchUp and click on the 3skeng symbol in the 3skeng toolbar. 

 

b) The 3skeng activation window opens. 

 

 
 

c) Please enter your email-address: 

Current/Registered users: 

Enter the same e-mail that you used previously for 3skeng activations & purchases (already user). 

In case you forgot: The address can be found by opening a previous version of SketchUp where an 

earlier version of 3skeng was installed. Click on the 3skeng symbol in the 3skeng tool palette. The 

email address that was used to previously register 3skeng will be displayed. 

New users: 

Enter an e-mail you have access to and want to use as the future user (new user). 

 

d) Select if you are already a 3skeng user or a new user.  

e) Fill out the short survey on the right with your main usage for 3skeng, your country (required) 

and your industry. 

f) Click on “get activation code”. 

g) Do not close the activation window.  
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4) Activation of 3skeng 

 

An activation key (one-time use) will be sent to the specified email address.  

 

 
 

If you do not get an email, make sure the email address is correct and check your junk email folder! 

   
 

a) Enter the activation code from the email in the appropriate field. 

b) Click on “activate…”. 

c) Allow 3skeng to download required files. Please have a little patience for this process... 

d) Restart SketchUp when prompted. 

e) Allow 3skeng to generate your local database after the restart of SketchUp.  
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5) Explanation of the client tab “my 3skeng” 

 

The 3skeng client tab “my 3skeng” (see screenshot) gives you an overview of your account: 

 

my 3skeng account 

Status:  Status of 3skeng installation 

Account: shows the account holder (e-mail address) that is currently activated. 

Version:  shows the 3skeng version that is currently installed. 

 

my 3skeng tools 

The current tool status is indicated by color-coded calendar symbols. The number shows the 

remaining use time available for the tool. 

Clicking on “manage tools…” allows you to add (purchase) annual licenses for tools. 

 

my 3skeng libraries 

Libraries for the “Pipe” and “Mount” tool with remaining use time are available for all tool versions. 

They require an extension in case they are expired. 

Clicking on “manage libraries …” allows you to add (purchase) annual libraries. 

 

 

 

Legend: 

 

my 3skeng account 

Status 

E-Mail address of 3skeng account holder 

Currently installed 3skeng version 

 

my 3skeng tools 

365-90 days of remaining use 

90-30 days of remaining use 

30-0 days of remaining use 

0 days of remaining use 

 

my 3skeng libraries 

library without expiration date 

365-90 days of remaining use 

90-30 days of remaining use 

30-0 days of remaining use 

0 days of remaining use 
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6) Add tools and libraries (purchase) 

 

Go to "manage tools" or “manage libraries” in the 3skeng client window tab “my 3skeng” to access 

the 3skeng webshop. 

 

The webshop offers comprehensive information about the tools. For detailed information on libraries, 

PDF files containing all the library elements (content) are available for each library. 

 

Learn more about the 3skeng license terms for tools and libraries here: 

http://www.3skeng.com/3s-products/License3skengEn.htm  

 

 

You can obtain your 3skeng license in the following ways: 

A) Use the 3skeng webshop  

You can purchase 3skeng licenses in the new SHK webshop! Payments are securely processed 

through the trusted providers Stripe and PayPal, supporting options like Credit Card (AMEX, JCB, 

MasterCard, and VISA), digital wallets and PayPal. Additionally, we offer the convenience of 

prepayment via bank transfer. 

After successful payment, you will receive an email with your invoice and a separate email for each 

user containing the purchased license(s). 

 

B) Buy 3skeng through resellers 

Browse to our website www.3skeng.com and go to “download -> buy 3skeng” where we provide a 

map with our resellers. Your purchased license(s) will be delivered by license card with transaction 

key.  

http://www.3skeng.com/3s-products/License3skengEn.htm
https://shop.shk.com/en-gb?route=common/home&language=en-gb
http://www.3skeng.com/
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7) How to use a transaction key 

 

Purchases in the 3skeng webshop and at resellers are handed over as personal transaction key. 

IMPORTANT: This key can only be used once to transfer licenses to your (activated) account. 

 

a) Go to "manage account" in the 3skeng client window tab “my 3skeng”. 

 

b) Type in your transaction key. 

 

c) Click on button “Activate transaction key and synchronize the database”. 

 

d) Your purchased 3skeng license(s) are added to your account (registered e-mail address) in the 

process. 

 

e) The transaction key is for one time use only and turns invalid after its activation in step d). 
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8) How to learn to use 3skeng  

 

3skeng was designed to follow the easy and intuitive use of SketchUp and at the same time provide 

powerful and useful functionality. 

 

To bring you up to speed with what you can do with 3skeng tools, we provide learning files in 

SketchUp format. 

 

The files guide you through the available functions of the tools scene by scene.  

You are asked to use specific values and angles to allow you to compare your result with the 

specified result at the end. 

 

Pdf-files that contain the scene descriptions in case you have trouble to read the texts on your 

screen are also available for download. 

 

We recommend to use the given file order and just skip tools (files) you are not interested in.  

Click the following links to download the individual files or an archive that contains all files: 

 

Learn to use (0.1) 3skeng List Select & Edit (skp) 

Learn to use (0.1) 3skeng List Select & Edit (pdf with scene text) 

 

Learn to use (1.1) 3skeng Pipe conceptual (skp) 

Learn to use (1.1) 3skeng Pipe conceptual (pdf with scene text) 

Learn to use (1.2) 3skeng Pipe detail basics (skp) 

Learn to use (1.2) 3skeng Pipe detail basics (pdf with scene text) 

Learn to use (1.3) 3skeng Pipe detail advanced (skp) 

Learn to use (1.3) 3skeng Pipe detail advanced (pdf with scene text) 

 

Learn to use (2.1) 3skeng Mount basics (skp) 

Learn to use (2.1) 3skeng Mount basics (pdf with scene text) 

Learn to use (2.2) 3skeng Mount advanced (skp) 

Learn to use (2.2) 3skeng Mount advanced (pdf with scene text) 

 

Learn to use (3.1) 3skeng Steelwork basics (skp) 

Learn to use (3.1) 3skeng Steelwork basics (pdf with scene text) 

Learn to use (3.2) 3skeng Steelwork advanced (skp) 

Learn to use (3.2) 3skeng Steelwork advanced (pdf with scene text) 

 

Learn to use (4) 3skeng Channel (skp) 

Learn to use (4) 3skeng Channel (pdf with scene text) 

 

Learn to use (5) 3skeng compatible Components (skp) 

Learn to use (5) 3skeng compatible Components (pdf with scene text) 

 

Learn to use 3skeng (0)-(5).zip (skp’s & pdf’s with scene text) 

 

Learning files for previous 3skeng 2018/2017/2016/2014 versions: 

Learn to use 3skeng (1)-(7).zip (skp’s & pdf’s with scene text)  

http://www.3skeng.com/download/Learn-to-use-(0.1)-3skeng-List-select-edit_ver.2.1.skp
http://www.3skeng.com/download/Learn-to-use-(0.1)-3skeng-List-select-edit_ver.2.1.pdf
http://www.3skeng.com/download/Learn-to-use-(1.1)-3skeng-Pipe-conceptual_ver.2.3.skp
http://www.3skeng.com/download/Learn-to-use-(1.1)-3skeng-Pipe-conceptual_ver.2.3.pdf
http://www.3skeng.com/download/Learn-to-use-(1.2)-3skeng-Pipe-detail-basics_ver.2.1.skp
http://www.3skeng.com/download/Learn-to-use-(1.2)-3skeng-Pipe-detail-basics_ver.2.1.pdf
http://www.3skeng.com/download/Learn-to-use-(1.3)-3skeng-Pipe-detail-advanced_ver.2.2.skp
http://www.3skeng.com/download/Learn-to-use-(1.3)-3skeng-Pipe-detail-advanced_ver.2.2.pdf
http://www.3skeng.com/download/Learn-to-use-(2.1)-3skeng-Mount-basics_ver.2.2.skp
http://www.3skeng.com/download/Learn-to-use-(2.1)-3skeng-Mount-basics_ver.2.2.pdf
http://www.3skeng.com/download/Learn-to-use-(2.2)-3skeng-Mount-advanced_ver.2.1.skp
http://www.3skeng.com/download/Learn-to-use-(2.2)-3skeng-Mount-advanced_ver.2.1.pdf
http://www.3skeng.com/download/Learn-to-use-(3.1)-3skeng-Steelwork-basics_ver.2.1.skp
http://www.3skeng.com/download/Learn-to-use-(3.1)-3skeng-Steelwork-basics_ver.2.1.pdf
http://www.3skeng.com/download/Learn-to-use-(3.2)-3skeng-Steelwork-advanced_ver.2.2.skp
http://www.3skeng.com/download/Learn-to-use-(3.2)-3skeng-Steelwork-advanced_ver.2.2.pdf
http://www.3skeng.com/download/Learn-to-use-(4)-3skeng-Channel_ver.2.2.skp
http://www.3skeng.com/download/Learn-to-use-(4)-3skeng-Channel_ver.2.2.pdf
http://www.3skeng.com/download/Learn-to-use-(5)-3skeng-compatible-Components_ver.2.1.skp
http://www.3skeng.com/download/Learn-to-use-(5)-3skeng-compatible-Components_ver.2.1.pdf
http://www.3skeng.com/download/Learn-to-use-(0)-(5)-3skeng_ver.2.3.zip
http://www.3skeng.com/download/Learn-to-use-(1)-(7)-3skeng_ver.1.1.zip
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9) 3skeng compatible elements / equipment / facilities / components 

 

The available libraries includes selected standard parts for piping, tubing and ductwork. 

There are many manufacturers for many different applications (e.g. pumps, fans, air handling units, 

valves, dampers, etc.) available on the market. So we are well aware that we cannot fulfill our 

users’ expectations concerning library content (e.g. valve types and sizes) and nature of available 

libraries (e.g. no air handling unit library). 

 

So we decided to provide a solution / workflow to make your own parts, equipment, facilities and 

components (e.g. drawn by yourself, 3D warehouse, etc.) compatible to 3skeng functions. 

We recommend that you set up your own SketchUp library file(s) that includes all the customized 

elements you need in your daily workflow. 

 

The parts, equipment, facilities and components you create won’t become a part of a 3skeng library 

directly but 3skeng recognizes integrated reference points and will select the appropriate pipe or 

connectors (e.g. Flange, VCR-f, etc.) for line attachment and can also work with the functions 

edit/rotate and connect (e.g. facility / utility connections of an air handling unit). 

 

You just have to consider that the right-click function “select line/all connected” doesn’t select these 

3skeng-compatible parts as part of the line (if you don’t right-click after selecting on all them). This 

is because this “3skeng compatible component” function can also be used for machines with 

connections of different utilities and we don’t want to select all lines with different pipe materials and 

different utilities. 

 

The fastest way to make a component compatible to the 3skeng tools is simply to add appropriate 

3skeng elements (e.g. flange) or pieces of pipe in that component.  

 

Learn more in chapter 8 where you can get a learning file that guides you through the process of 

making 3skeng compatible components. 
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10) Answers for the most frequent questions 

 

3skeng freezes for a longer period of time during some situation / operations? 

Please minimize the trays “Components” and “Outliner” as they requires lots of computing power 

and may lead 3skeng (and other extensions) to freeze! 

 

 

 

 

 

How can I get my 3skeng licenses up and running again in case I have a new computer or 

new SketchUp version or new 3skeng version? 

Please follow the guide starting from chapter 1 and following. 

Please consider: It is very important that you use the same email address that you used for initial 

activation and purchases to continue using your licenses! 

 

 

I have problems with my libraries for some reason (e.g. interrupted or defective 

download). How can I force 3skeng to synchronize the content? 

Please click on the menu:  

“Extensions \ 3skeng Engineering 20xx \ maintenance \ Check for update… …”. 

That will trigger 3skeng to synchronize your installation. When prompted, please restart SketchUp 

and allow it to rebuild the local database. 

 

 

How can I use another e-mail address (account) for my 3skeng installation? 

Please click on the menu: 

“Extensions \ 3skeng Engineering 20xx \ maintenance \ Reset local Database…”.  

That will reset 3skeng and require a new 3skeng activation (please see chapter 4 of that guide). You 

can enter another e-mail address at that step. 
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11) How to deactivate and / or uninstall 3skeng 

 

Deactivate 3skeng  

To deactivate 3skeng, untag it in: 

MAC OS: “View -> Tool Palettes” (dropdown menu).  

Windows OS: “View -> Toolbars…” 

 

        

 

 

 

 

 

 

 

 

 

 

 

Uninstall 3skeng 

Please deactivate 3skeng (see above), close SketchUp and manually delete the following: 

 

Delete “3skeng 2024” database folder: 

C:\Users\%username%\AppData\Roaming\3skeng_V2024\Sketchup 20xx 

 

Delete “3skeng 2023” database folder: 

C:\Users\%username%\AppData\Roaming\3skeng_V2023\Sketchup 20xx 

 

Delete “3skeng 2022” database folder: 

C:\Users\%username%\AppData\Roaming\3skeng_V2022\Sketchup 20xx 

 

Delete 3skeng Plugin in SketchUp program folder: 

In Path C:\Users\%username%\AppData\Roaming\SketchUp\SketchUp 20xx\SketchUp\Plugins 

Delete folder “\shk_3skeng\” and file “shk_3skeng.rb” 


